407-248-1481

QuoteWerks Knowledgebase Topic (Article ID 7770)

Integrations - DLL presents an interface mismatch error

This information applies to :

Article ID
7770

Created/Updated
December 8, 2017

Category


Are you using the most current release of QuoteWerks?
Version 5.5 Build 1
Issue:

"The interface version of the [INTEGRATION.DLL] file on your system does not match the interface version expected by this Build of QuoteWerks," during the operation of QuoteWerks (typically encountered when retrieving a contact from the CRM/PSA). The error may also be encountered when loading QuoteWerks (it will remark that the QWOS.DLL is mismatched) or when retrieving product information via the Product Content Subscription powered by Etilize (it will remark the QWServices.DLL is mismatched).
The error message will then proceed to detail the expected and found versions of the file. If this error message is The integration DLL was not overwritten at the time of the Nsetup.



Solution:

The end user will need to conduct the following:

1) go to the Windows Control Panel, and uninstall the Node Setup Completely

2) go to "C:\Program Files (x86)\Common Files\" and delete the QuoteWerks folder

3) go to the QuoteWerks directory that houses QuoteWerks, and run the Nsetup

3a) make sure when running the Nsetup, that the option for the integration in question is checked (e.g. Autotask, ConnectWise, etc.)


The issue should be resolved after these steps.


NOTE:
-----------
These steps apply to QuoteWerks Version 5.0 and above.

New Search