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QuoteWerks Knowledgebase Topic (Article ID 6496)

Error - No More Available Unique Backup File Names

This information applies to :

Article ID
6496

Created/Updated
July 17, 2019

Category
Support


Are you using the most current release of QuoteWerks?
Version 24.0 Build 2
Issue:

When working with a QuoteWerks document you get the following error:

(Note: The error message may slightly vary depending on the document number referenced in the error and the path of your QuoteWerks installation directory)

"There are no more available unique backup file names .B01 - .B99 for the file 'AAAQ1523.dtf.' Please delete some of the these temporary files from the \\servername or drive\quotewerks\DTF directory




Cause:

Each time a backup is made of a document, or you synchronize QuoteWerks documents through your contact manager, a unique sequential extension is generated, starting with .B01. The highest numbered extension is the newest backup. The backup documents are stored in the QuoteWerks\DTF directory. This feature will allow you to restore a quote that has been incorrectly replaced by a different location’s quote. A backup copy of the quote will be saved to a file in the QuoteWerks\DTF directory. The file will have the same base name as the document number, and will have a unique sequentially numbered extension. For example: Document # A101, the backup file name would be A101.B01, A101.B02, A101.B03 etc. Each time the quote is backed up, QuoteWerks will increment the extension, so the latest backup will be the highest numbered extension. The extensions will continue to increment up to .B99. This means that QuoteWerks has made 99 backups of the same file. 99 backups of the same file is the maximum allowed.

Note: If a backup file is deleted out of sequence, QuoteWerks will replace that file the next time a backup is created, so you will want to double-check the date of file also.

For example: If you have files .B01 - .B99, and you delete .B01-.B90, QuoteWerks will start the next backup file at .B01


Solution:

Once you get this message, you need to delete some or all of the backup files. You can easily delete all the backups, and run the maintenance again, which will immediately create a new set of backup databases from which to restore from, if required. You may want to take the most recent backup files, and shift them off to a safe storage area for a period of time -- just in case


The DTF files are essentially "redundant" backups. You can safely delete these file as the message in your screenshot indicates. DTF files are a "flat file" representation of a record in your documents database. Your documents database is where the documents are truly stored and this is what you should be backing up.

For more information on the QuoteWerks files that should be backed up in QuoteWerks, please refer to Article 6056 in the QuoteWerks Knowledgebase:
https://www.quotewerks.com/kbase/showArticle.asp?id=6056

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