407-248-1481

QuoteWerks Knowledgebase Topic (Article ID 6370)

ACT! - Error Creating Attachment Record

This information applies to :

Article ID
6370

Created/Updated
June 13, 2023

Category
Troubleshooting


Are you using the most current release of QuoteWerks?
Version 24.0 Build 1
Issue:

When saving an attachment to ACT, you receive the following error or similar (the path in the error will vary according to your QuoteWerks installation path. Your version of ACT may also vary from the version listed in the error):

Run-time error -2146233076
Type 'ACT.Framework.SupplementalFiles.AttachmentException' in Assembly' ACT.Framework, Version=9.0.175.0, Culture=neutral,
PublicKeyToken='ebf6b2ff4do8o8aa' is not marked as serializable.

or

Error creating attachment record in ACT!
Details=F:\QuoteWerks\DTF\aaaq1000
Name=[Docname]
LastError=Type 'ACT.Framework.SupplementalFiles.AttachmentException' in Assembly' ACT.Framework, Version=9.0.175.0, Culture=neutral,
PublicKeyToken='ebf6b2ff4do8o8aa' is not marked as serializable.



Cause 1:

You do not have sufficient folder permissions for the ACT Supplemental Files folder

Solution 1:

Have your ACT administrator or IT person increase the folder permissions to the ACT Supplemental Files folder. We recommend Full Control folder permissions.

Cause 2:

The QuoteWerks ACT! link has not installed correctly.

Solution 2:

With ACT! and QuoteWerks closed, go to Control Panel -> Add/Remove Programs and remove the node and/or QuoteWerks ACT! Link.

Run the MachineConfigUpdater.EXE located in the Act For Windows Folder (typically located in C:\Program Files\ACT\Act for Windows). This file may only be available in ACT! 10.0.3 and higher.

Next, open the QuoteWerks installation folder and double click and run nsetup, being sure to check the box to install the Act! Desktop integration. Once that runs, relaunch ACT! and relaunch QuoteWerks to test the integration.

Cause 3:

Windows User Account Control is interfering with the integration.

Solution 3:

Disable UAC through Control Panel -> User Accounts.

Cause 4:

As of QW 5.7 build 7.03 and higher:
Missing .net 3.5 Framework


Solution 4:

Install .net framework 3.5 and reboot.

New Search