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QuoteWerks Knowledgebase Topic (Article ID 6228)

Error When Saving - Next Available QUOTE Number (Corporate Edition Rehosted to SQL)

This information applies to :

Article ID
6228

Created/Updated
July 17, 2019

Category
SQL


Are you using the most current release of QuoteWerks?
Version 24.0 Build 2
Issue:

When saving a quote to a Corporate Edition installation (Rehosted to SQL) an error message appears:


An Error occurred while trying to get the next available QUOTE number. Do you want to try again?

Cause:

The ID field located in the DocumentNumbering table has a value other than 1.

Solution:

QuoteWerks Technical Support does not provide support for backend operations including the following steps. Please backup your data prior to performing the following:.

Your SQL Administrator will need to make this change as it requires operations on the backend of the QuoteWerks SQL database.

**Have all users log out of QuoteWerks before performing the following process**

1. Open Enterprise Manager and then open the QuoteWerks database.

2. Select Tables and then right-click on the DocumentNumbering table and then click Design Table.

3. Scroll till the Column Name list and select ID.

4. Right-click on ID and Set Primary Key will have a check mark next to it. Click on Set Primary Key and the check mark will be removed.

5. On the column tab below, change the value for Identity from "Yes" to "No" (omitting quotes).

6. Click the Disk icon to save the changes.

7. Close the Design Table view and return to the tables list. Right-click on DocumentNumbering and select Open Table > Return all rows.

8. Scroll right to the ID field and update the value to be "1" (omitting quotes).

9. Click off of the field and then close the Open Table window.

10. Right-click on the DocumentNumbering table and then click Design Table.

11. Scroll till the Column Name list and select ID.

12. On column tab below, change the value for Identity from "No" to "Yes" (omitting quotes), then right-click on ID and click on Set Primary Key to add the checkmark back.

13. Click the Disk icon to save the changes.

14. Close the QuoteWerks database. The application can now be restarted.

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