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QuoteWerks Knowledgebase Topic (Article ID 6137)

Database - Performance Issues

This information applies to :

Article ID
6137

Created/Updated
July 17, 2019

Category
Troubleshooting


Are you using the most current release of QuoteWerks?
Version 24.0 Build 2
Issue:

QuoteWerks has suddenly begun to run slowly or there has been decreased perfomance speed.

Cause:

There are several factors that can influence the performance of a Server/Client application such as QuoteWerks. Generally speaking, when an application "suddenly" begins operating slowly, a good place to start troubleshooting is your network environment, such as bandwidth, concurrent usage, other applications, and hardware constraints.

Solution:

- Using the QuoteWerks Medic Utility, run Maintenance on your QuoteWerks databases if you are not using the Corporate Edition rehosted to MS SQL. The Medic Utility can be accessed in Start->Programs->QuoteWerks ->Tools and Information->Medic Utility. Once you press the Maintenance Button, you will see a list of all your databases. Right-click on any of them and select-all. Once the databases are highlighted, press the Start Button.

- Temporarily disable your Anti-virus and Firewall software to check to see if performance improves. Certain features of these types of programs can significantly impact performance. If you disable the Antivirus and discover that it is impacting performance, some antivirus programs can be set to exclude certain files or folders. If so, you will want to add the QuoteWerks Directory to the list of files that your antivirus scans, or, at a minimum, you can simply add the files that have a *.mdb, *.ini, and *.exe file extension from the QuoteWerks Directory.


- Check the Windows Task Manager running on your workstations to check the performance of the QuoteWerks Node (client) for items such as total applications running in the background, memory and processor usage, and network usage statistics.

- Check to see if you have recently installed new programs and if so, check to see if they may be affecting QuoteWerks or other applications.

- Check to see if you have opted for QuoteWerks to "Show all products/services when database source is selected" when a database is selected. If you have several thousands of parts, this may take several moments to load depending on some of the factors listed above. You can check to see if you have selected this option by selecting the ProductsSetup Products Sources menu and highlighting the database, and selecting Edit. At the end of the database setup/edit, you will find the checkbox labeled "Show all products/services when database source is selected." If it is checked, uncheck it to see if it makes a difference in QuoteWerks when accessing the products database.

- If you have run Maintenance and found that, afterwards, your docs.mdb (documents database) is exceeding 100Mb, you may wish to Purge and Archive older QuoteWerks documents to decrease the database size. You can do this by selecting the Utilities->Document Purge Wizard. If after purging documents or if purging is not an option, your database still exceeds 100Mb, you may want to consider rehosting your QuoteWerks databases to a SQL backend. The QuoteWerks Corporate Edition's main feature is its capability to rehost its native databases to a SQL database. (SQL not included)

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