407-248-1481

QuoteWerks Knowledgebase Topic (Article ID 5886)

Consistent Errors on a Network Installation of QuoteWerks

This information applies to :

Article ID
5886

Created/Updated
July 16, 2008

Category
Database


Are you using the most current release of QuoteWerks?
Version 5.5 Build 1
Issue:
Increased Risk of Database Corruption

Cause:
Opportunistic Locking (oplocks) on the Network File Server
Microsoft has discovered an issue where opportunistic locking can increase the risk of Jet database corruption when the file is shared by two or more clients on a network file server. This issue applies to Microsoft Windows NT 4.0, Microsoft Windows 2000, and Novell file servers that support opportunistic locking. This issue also applies to clients that are running Microsoft Windows NT 4.0, Microsoft Windows 2000, or Microsoft Windows XP, and that connect to a file server that supports opportunistic locking.

Solution:

Windows 2000

To avoid the problem on computers that are running Windows 2000, you must install Windows 2000 Service Pack 3 (SP3) on the Windows 2000 file server where the Access database file is located, and then on each Windows 2000 client computer that connects to the Windows 2000 file server. For information about how you can obtain and how you can install Windows 2000 SP3, read the following Knowledge Base article:

260910 How to Obtain the Latest Windows 2000 Service Pack
http://support.microsoft.com/default.aspx?scid=kb;EN-US;260910

If you have Microsoft Windows 95, Microsoft Windows 98, Microsoft Windows Millennium Edition (Me), or Microsoft Windows NT 4.0 clients, you do not have to install the service pack that is mentioned in the Knowledge Base article Q260910 on these clients.

Windows XP

To avoid the problem on computers that are running Windows XP, install the hotfix that is mentioned in the following Microsoft Knowledge Base article on each Windows XP client computer that connects to the file server where the Access database is located.

309376 A Long Time Is Needed to Open a File By Using SMB
http://support.microsoft.com/default.aspx?scid=kb;EN-US;309376

If you have Microsoft Windows 95, Microsoft Windows 98, Microsoft Windows Millennium Edition (Me), or Microsoft Windows NT 4.0 clients, you do not have to install the hotfix that is mentioned in the Knowledge Base article Q309376 on these clients.

New Search