Please enable JavaScript to view this site.

QuoteWerks Help
Version 24 (Build 1.04) 
December 12, 2023
  •      

Navigation: QuoteWerks Help > CHAPTER 29: Open Export Module

Setting Up the Open Export Module

Scroll Prev Top Next More

Select the Tools -> Export using Open Export module menu to display the Open Export Module window. The first step of the Export Wizard will be displayed:

XML Export Setup

To get into the setup for the xml export, you need to click on the [Next] button to move past the first step. The second step is “Select Export Format”:

The XML export has no setup options. On this step, when you select “Export as XML”, the [Setup] button will be disabled.

For more information and next steps, see Using the Open Export Module to Export XML.

Delimited Text Export Setup

To get into the setup for the delimited text export, you need to click on the [Next] button to move past the first step. The second step is “Select Export Format”:

On this step, you can select “Delimited Text”, and click on the [Setup] button to display the Setup window.

For more information and next steps, see Using the Open Export Module to Export Delimited Text.

Document Header Fields Tab

On the Open Export Module Setup window, choose the Document Header Fields tab to specify which of the DocumentHeader fields you would like to export to the text file, and in what order. Place a checkmark next to each field you would like to export. To specify the order in which the fields are exported, select a field, and use the up and down arrow buttons to re-position it.

Document Items Fields Tab

On the Document Items Fields tab choose the Document Items Fields tab to specify which of the DocumentItems fields you would like to export to the text file, and in what order. Place a checkmark next to each field you would like to export. To specify the order in which the fields are exported, select a field, and use the up and down arrow buttons to re-position it.

Options Tab

On the Options tab you can specify several options:

Field Delimiter

This option lets you choose how to separate the field data in the export file. You can choose tab or comma delimiters.

Include field names

If this option is checked then the exported data will contain the names of the fields being exported on the first line of the text file.

Do not export Comment Lines

QuoteWerks documents can contain several types of line items such as comments, subtotals, running subtotals, etc. This option lets you choose to not export Comment line items.

Do not export Heading Lines

QuoteWerks documents can contain several types of line items such as comments, subtotals, running subtotals, etc. This option lets you choose to not export Heading line items.

Destination Tab

On the Destination tab you can specify options for the text file that will be created. Quote data can be separated into two areas – the header and the items. The header data includes the contact information, address, terms, etc. The item data includes all the line items in the quote.

Export header and item data into separate files

Choose this option to export the header and item data into two separate files. Accounting software like Great Plains is designed to imporing header and item data that is separate files.

Header Export File

Here you can specify what folder you want to save the header data file into and also the name of the file.

Items Export File

Here you can specify what folder you want to save the items data file into and also the name of the file.

Export header and item data into a single file

Choose this option to export the header and item data into the same file. Inventory software like FishBowl is designed to import header and item data that is in the same file.

Export File

Here you can specify what folder you want to save the header and item data file into and also the name of the file.

Header record identifier

When both the header and item data is exported into the same file, there needs to be a way to indicate what type of data each line contains – either header data or item data. The value that you specify for the header record identifier will appear in the first column of every header data line in the text file.

Item record identifier

When both the header and item data is exported into the same file, there needs to be a way to indicate what type of data each line contains – either header data or item data. The value that you specify for the header record identifier will appear in the first column of every header data line in the text file.